Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 21
  1. #11
    Senior Member Lee C's Avatar
    Join Date
    Jul 2014
    Location
    lost in the blinding whiteness of the tundra
    Posts
    580
    More often than not yes I do, doesn't take more than a couple of minutes. Bikes usually in workstand so easy enough.

  2. #12
    Senior Member coolboarder's Avatar
    Join Date
    Jul 2004
    Location
    Iver, Bucks
    Posts
    9,559
    Quote Originally Posted by Lee C View Post
    More often than not yes I do, doesn't take more than a couple of minutes. Bikes usually in workstand so easy enough.
    I just spin the cranks for one complete resolution of the chain while dribbling the Squirt onto it. Seems to work for me and takes 10 seconds with the bike propped up on the floor.
    It doesn't matter how many times you fall down, its how times many you get back up that count.

  3. #13
    Senior Member Lee C's Avatar
    Join Date
    Jul 2014
    Location
    lost in the blinding whiteness of the tundra
    Posts
    580
    Yea most people do it that way but being a careful (tight) Yorkshireman I canny b doin wi putting on more than I need just to wipe it off. I don't use the bottle it comes in but transfer it to one with a long much thinner nozzle, works a treat. First saw it done in my lbs and iv done it eversince.

  4. #14
    Senior Member
    Join Date
    Jul 2004
    Posts
    1,703
    I apply the same way as Lee - wouldn't say it was time consuming, quick dab on each pin as you rotate the cranks and no waste (but then I'm also from Yorkshire ).

  5. #15
    Just checked the chain again, and it's definitely sticky - when you push down on the chain with your index finger and then lift your index finger away the chain remains attached to the finger and list itself up for about 2 mm before it releases itself.

    To me that's too sticky.

    Maybe I've got a bad batch or it's been stored too cold.

    I've just ordered some muc off ceramic dry lube.....

  6. #16
    Senior Member Lee C's Avatar
    Join Date
    Jul 2014
    Location
    lost in the blinding whiteness of the tundra
    Posts
    580
    Fair enough but with all due respect it's not the squirt thats at fault you've applied to much.

  7. #17
    Senior Member
    Join Date
    Nov 2014
    Location
    Clevedon, UK
    Posts
    1,547
    It's possible the chain wasn't degreased enough.

  8. #18
    Quote Originally Posted by OETKB-YENTC View Post
    It's possible the chain wasn't degreased enough.
    Hmmm....I used Jizer in a park tools chain bath - twice- then washed any degreaser off by spraying with Hope Shit Shifter and rinsed off with a hosepipe set to fine spray.

    Got me foxed ....

  9. #19
    Finally got round to removing the squirt and replacing it with muc off ceramic dry lube which after a couple of hours has a much less sticky feel than the squirt.

    If anyone wants an almost full bottle of squirt, message me your address and I will send it to you - I hate waste....

  10. #20
    Senior Member coolboarder's Avatar
    Join Date
    Jul 2004
    Location
    Iver, Bucks
    Posts
    9,559
    Quote Originally Posted by Peter Cee View Post
    Hmmm....I used Jizer in a park tools chain bath
    A chain bath is not effective enough to get the grease out of the links, the stuff the chain comes with is very resilient. I put the chain in an old baking tray submerge it in Muc Off and clean each link individually with a toothbrush from all 4 sides, rinse off with warm water and hang to dry. It is then squeaky clean, the Squirt can be applied (sparingly) and the chain will never have to be cleaned again.
    It doesn't matter how many times you fall down, its how times many you get back up that count.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •